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GIS Facilities at the University of Maryland 

McKeldin Library 

ArcGIS 10.5 and QGIS (an open source GIS software package) are loaded on all public 
workstations in McKeldin Library, including those located in the McKeldin 6101 instruction 
laboratory. The laboratory is open to the public during library hours when not in use by a class 
or librarian. The laboratory schedule is posted on the window by the door and updated each 
week. Color printing and large format printing are also available in McKeldin Library.  

The GIS laboratory is located on the fourth floor of McKeldin Library in room 41218 This 
laboratory is available for use by faculty, staff, and students using geospatial methods in their 
research at the discretion of GIS and Spatial Data Center Staff.  ArcGIS 10.5 and QGIS are 
installed on all computers in this laboratory, as well as other geospatial, image processing, 
and statistical packages.  

For a complete list of software packages available, please see our GIS Facilities link 
https://www.lib.umd.edu/gis/people-and-facilities 

Other Facilities 

There are other departmental (e.g., anthropology, architecture/urban planning, civil 
engineering, geographical sciences, and landscape architecture) GIS laboratories on campus 
that are restricted to faculty, staff, and students in each of those disciplines. Additionally, the 
Office of Information Technology's software licensing program (http://www.oit.umd.edu/slic) 
offers ArcGIS at special/reduced rates for faculty and staff at the University of Maryland. 

https://www.lib.umd.edu/gis/people-and-facilities
http://www.oit.umd.edu/slic
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Introduction 

A GIS (Geographic Information System) is a powerful tool used for computerized mapping and 
spatial analysis. A GIS provides functionality to capture, store, query, analyze, display and 
output geographic information.  

For this seminar we will be using ArcGIS Desktop 10.5, the newest version of a popular GIS 
software produced by ESRI. This course is meant to teach some fundamental GIS operations 
using ArcGIS. It is not meant to be a comprehensive course in GIS or ArcGIS. However, we hope 
this seminar will get you started using GIS and excited about learning more. 
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Extensions to ArcGIS 
 
ArcGIS has additional, optional software modules that add specialized tools and functionality to 
ArcGIS Desktop. ArcGIS Network Analyst, ArcGIS StreetMap, and ArcGIS Business Analyst are 
examples of ArcGIS extensions. Source: The GIS Dictionary at ESRI.com.  
 
For example:  
 

● 3D Analyst 

● Geostatistical Analyst 

● Spatial Analyst (provides spatial modeling and analysis features. It allows the creation, 
querying, mapping, and analysis of cell-based raster data and integrated vector-raster 
analysis)  

● Survey Analyst  
● Tracking Analyst 

 
 
 

Geoprocessing through ArcToolbox 
 
According to ESRI, geoprocessing refers to the tools and processes used to generate derived 
data sets. What is derived data? The derived data is a new file that results from taking a data 
layer and processing it.  
 
There are many ways to conduct geoprocessing. In fact, there are over 200 within ArcGIS 
Desktop. This tutorial will NOT show you how to use all of them, but we will look at five of the 
most common geoprocessing operations: buffer, clip, dissolve, intersect, and spatial join. See 
the table at end of the Five Common ArcToolbox Tools for details. 
 
ArcToolbox allows us to perform these operations through sets of toolboxes. We will be using 
the Analysis and Data Management toolboxes. Within these main toolboxes, operations are 
grouped by the way that the derived data set is created.  
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Exercise: Creating New Shapefiles (Two Ways) 
 

Creating from scratch/by tracing 
 
We will be creating our shapefile within ArcCatalog and then adding it to ArcMap.  
 
Let’s first download the data we’ll need for the exercises. Go to 
https://www.lib.umd.edu/gis/workshops and click on Data under Spatial Analysis workshop 
details. Make sure the data is downloaded to the Downloads folder. Go ahead and unzip the 
data by right clicking on the folder and clicking on extract. Now you should have the data 
required in the Downloads folder. 
 

1. Open ArcCatalog.  
2. First we must highlight the folder in which we wish to create the shapefile in the 

catalog tree. Navigate to C:\USERS\”YourDirectoryID”\DOWNLOADS\Data.   Highlight 
the Data folder. Click on the Connect to Folder icon and  

 
3. Once the appropriate folder is selected we can create a new shapefile. Go to the Menu 

Bar (or right click on the highlighted folder) and select File > New > Shapefile. The 
‘Create New Shapefile’ dialog box will appear.  

4. First we must give our new shapefile a name. Type “MontCo_dams” in the Name box.  
5. Next we must tell the computer whether we are creating a point file, a polyline file, or a 

polygon file. Choose point file in the ‘Feature Type’ dropdown box.  
 

We also have the option to tell the computer the coordinate system we wish the data to be 
displayed in.  

 
6. Select the edit button. The Spatial Reference Properties dialog box will open.  
7. Open the Projected Coordinate Systems folder by double clicking.  
8. Open the State Plane folder by double clicking.  
9. Open the NAD 1983 (US Feet) folder by double clicking.  
10. Select the NAD 1983 State Plane Maryland FIPS 1900 (US Feet) file and click ‘OK’.  
11. Once you have returned to the Spatial Reference Properties dialog box click ‘OK’.  

 

https://www.lib.umd.edu/gis/workshops
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12. Once you have returned to the Create New Shapefile dialog box click ‘OK’.  
 

 
 
The MontCo_Dams file now appears in the Contents Tab of the Catalog Display. We can now 
create the column headings for our attribute table. 
 

1. Double click on the MontCo_Dams file in the contents tab of the catalog display. The 
Shapefile Properties dialog box opens.  

2. Select the Fields tab. The fields titled FID, Shape, and id are automatically added to each 
shapefile. We are going to add a field. 

3. Select the box in the Field Name column below Id. You can now type directly into the 
box. We are going to call this field “Name.” When creating new fields, keep in mind that 
ArcGIS will reject titles that have too many characters and titles with spaces.  

4. In the Data Type column, select Text from the drop-down box.  
5. Under Field Properties we may choose the number of characters to be allowed in this 

field. For our purposes we will keep the default of 50.  
6. Click ‘OK’.  
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We are now going to add our new shapefile to ArcMap. When we add the new shapefile it will 
appear in the table of contents but nothing will appear on the screen. This is because we have 
not yet created any points for our shapefile.  

Open ArcMap from ArcCatalog by clicking on the Launch ArcMap icon   .   Minimize 
ArcCatalog. Once ArcMap opens: 
 
Before we start, let’s make sure the Spatial Analyst extension that we need for these exercises 
is turned on.  
 
Go to Customize tab that you see at the top and click on extensions and check the box next to 
Spatial Analyst. 
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1. Choose ‘A new empty map’ and click ‘OK’.  

2. Select the add data button  

3. Navigate to C:\USERS\”YourDirectoryID”\DOWNLOADS\Data and select the 
MontCo_Dams file we just created.  

4. Click ‘Add’.  
 
We are also going to add the Montgomery County file titled “county.shp”. Click on the ‘Add 

Data’ icon and navigate to C:\USERS\”YourDirectoryID”\DOWNLOADS\Data to find this 
file. If you do not see the file, it may be that your scale is too large—either zoom in or make 
your scale larger (try 1:400,000). 
 
We are going to create the points for our new point file by using a point file that was 
downloaded from the National Map Seamless Server.   
 

1. Use the ‘Add Data’ icon, navigate to C:\USERS\”YourDirectoryID”\DOWNLOADS\Data 
and add ‘md_dam_points.shp’.  
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You can see that this is a file containing points for dams in and around Montgomery County.  
We will trace points for only those dams that are within our county boundary.  To do this we 
must use the Editor toolbar. If the Editor toolbar is not currently displayed, go to the menu bar 
and select Customize > Toolbars > Editor.  
 

 
 
From the Editor toolbar select Editor > Start Editing. The computer will ask you which folder 
you wish to edit from. Select ‘md_dam_points.shp’ and press Continue.  
 
 
On the Editor Toolbar we want to select the task Create New Feature by clicking on this icon:  
 

 
 
A “Create Features” window will open on the right side of the screen.  We will be creating 
points, so you may need to click the drop-down and choose Filter By > Point as shown below. 
 

 
 
Click on the ‘MontCo_Dams’ file name in the Create Features box to select the file for editing. 
 
Now the point icon on your Editor toolbar should be active.  Click on the point icon.  (You’ll 
notice that your cursor changes to an arrow with a point.)  
 

 
 
We are going to use the mouse to draw a point over top of each dam that is within 
Montgomery County. You will see that the tool automatically zooms and centers the points you 
want to trace when you hover over them. To place a new point on the map, left click once with 
the mouse. Each time you click on the map it will create a new point.  

 

 



 

13 

 

 
When you have finished placing all of your points on the map, go back to the Editor Toolbar and 
select Editor > Save Edits. After you have saved your edits select Editor > Stop Editing.  
 
Turn off all layers except MontCo_dams and you will see that the shapefile you created now 
contains the points you traced.  Right click on MontCo_Dams and scroll down to Open 
Attribute Table.  The new points also show in your attribute table. From here we will input the 
names of the dams in the attribute table.  
 

1. If your editor toolbar is not currently active, go to the menu bar and select Customize > 
Toolbars > Editor. The editor toolbar should now appear.  

2. Using the editor toolbar select the ‘Editor’ button and scroll down to ‘Start Editing’.  
3. Select MontCo_Dams in your Layers list so it is highlighted in blue. Right click and 

open the attribute table.  
4. Place your cursor in the Name column of the attribute table and type the first dam 

name which is “Little Seneca.” You can widen the column by placing your cursor at the 
top of the column, holding the left mouse button and dragging it right.  

5. Place the cursor in the name column in each row to name that dam. Name the 
remaining dams:  Seneca State Park; Upper Rock Creek 5; Upper Rock Creek 1; and 
Furnace Run.  (In reality, each point corresponds to a specific dam, but for the purpose 
of this exercise we are not worried about labeling each dam correctly).  

6. When you have finished go to the editor toolbar and select Editor > Save Edits, then 
select Editor > Stop Editing.  

 

 
 

7. Close the attribute table.  
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That’s it!  You’ve created a point shapefile.  You could do the same by tracing from an aerial 
photograph, an old scanned map, etc.
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Creating by modifying an existing file 

 
You can create points, polylines, and polygons in ArcCatalog by using the same steps described 
above. But what if creating an entirely new shapefile is not conducive to what we are trying to 
accomplish? Let’s say we want to create a shapefile that breaks the state of Maryland into 
various regions. It would be very time consuming to trace the entire State of Maryland, and it 
would also be very inaccurate. Instead we can use our file of Maryland counties to create a new 
shapefile of regions.  
 
Let’s begin by creating a new shapefile in ArcCatalog like we just did for our point file.  

 

1. Open ArcCatalog .  
2. First we must highlight the folder in which we wish to create the shapefile in the catalog 

tree. Navigate to C:\USERS\”YourDirectoryID”\DOWNLOADS\Data in the catalog tree.  
3. Once the appropriate folder is selected we can create a new shape file. Go to the Menu 

Bar (or right click on the highlighted folder) and select File > New > Shapefile. The 
Create New Shapefile dialog box will appear.  

4. First we must give our new shapefile a name. Type “Sub regions” in the Name box.  
5. Next we must tell the computer whether we are creating a point file, a polyline file, or a 

polygon file. Choose polygon file.  
 

We also have the option to tell the computer the coordinate system we wish the data to be 
displayed in. We will use the same system as before—Maryland State Plane. 

 
1. Select the edit button. The Spatial Reference Properties dialog box will open.  
2. Open the Projected Coordinate Systems folder by double clicking.  
3. Open the State Plane folder by double clicking.  
4. Open the NAD 1983 (US Feet) folder by double clicking.  
5. Select the NAD 1983 State Plane Maryland FIPS 1900 (US Feet) file and click ‘OK’.  
6. Once you have returned to the Create New Shapefile dialog box click ‘OK’.  
 

The Subregions file now appears in the Contents Tab of the Catalog Display. We can now create 
the column headings for our attribute table. 
 

9. Double click on the Subregions file in the catalog tree. The Shapefile Properties dialog 
box opens.  

10. Select the Fields tab. The fields titled FID, Shape, and id are automatically added to each 
shapefile. We are going to add a field. 

11. Select the box in the Field Name column below Id. You can now type directly into the 
box. We are going to call this field “Subregion.” When creating new fields, keep in mind 
that ArcGIS will reject titles that have too many characters and titles with spaces.  

12. In the Data Type column, select Text from the drop-down box.  
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13. Under Field Properties we may choose the number of characters to be allowed in this 
field. For our purposes we will keep the default of 50.  

14. Click OK.  
15. Close ArcCatalog.  

 
Now that we have created our new shapefile, let’s go into ArcMap and start with a new, empty 
map.  We are going to re-add our new files. Do not save changes. We must first add the 

‘mdcounties’ shapefile to our map . This file can be found in 
C:\USERS\”YourDirectoryID”\DOWNLOADS\Data.  Next we must add the new Subregions 
shapefile we just created which is located in the same directory.  
 
We will break the State into four regions: Western Maryland, Southern Maryland, the Eastern 
Shore, and the Baltimore-Washington Metropolitan Area. To add labels to the counties in 
Maryland, right click on ‘mdcounties’ and scroll down to ‘Label Features’.  
 
We will use the mouse to select our first region, Western Maryland. To do this: 
 

1. Click on the ‘Select Features’ icon .  
2. Hold down the shift button on your keyboard and left click on Garrett, Allegany, 

Washington, and Frederick.  
3. If the editor toolbar is not visible, go to the menu bar and select ‘Customize > Toolbars 

> Editor’.  
4. Once your Editor toolbar is visible, select Editor > Start Editing.  
5. Select the Sub regions shapefile – this will cause the software to choose the correct 

source data for that shapefile to edit.   
6. Go to the Editor Toolbar once again and select Editor > Union.   
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If prompted to choose a template, click OK. 
 

 
 

7. Click the ‘Clear Selected Features’ icon .  
 
All of the counties we selected are now visible as one single region within the Subregions 
shapefile. We will now go through the same steps to create the regions of Southern Maryland 
(Calvert, Charles, and St. Mary’s), the Eastern Shore (Cecil, Kent, Queen Anne’s, Talbot, 
Caroline, Dorchester, Wicomico, Somerset, and Worchester) and the Baltimore-Washington 
Metropolitan Region (Carroll, Howard, Baltimore County, Baltimore City, Harford, Anne 
Arundel, Montgomery and Prince George’s).  Click ‘Clear Selected Features’ when you are 
finished. 
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After we have created our four new polygons, we can go into the attribute table and fill in the 
name for each region.  
 

1. Right click on Subregions and scroll down to ‘Open Attribute Table’.  
2. We are still editing Subregions so we can type directly into the attribute table. Label the 

four polygons we just created in the column titled ‘Subregion’.  
 

 
 
3. Close the attribute table. 
4. Save your edits (Editor > Save Edits) and stop editing (Editor > Stop Editing).  

 
We will also want to change the color of each region to make them distinctive.  

1. Right click on ‘Subregions’ and scroll down to properties.  
2. Select the Symbology tab in the Layer Properties dialog box.  
3. In the Show Box select Categories > Unique Values.  
4. In the Value Field dropdown box select ‘Subregion’.  
5. Click ‘Add All Values’. Choose red for Balto/Wash Metro Area, orange for Eastern Shore, 

yellow for Southern Maryland, and green for Western Maryland (or whatever colors you 
like).  

6. When finished click ‘OK’ and save the map. 
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Exercise: Five Common ArcToolbox Tools 
 

1. Buffer  
 
Our first geoprocessing task will be creating a new area around an already existing layer. This is 
called a Buffer. Buffers can be created around any of the vector file types—points, lines, and/or 
polygons. We will be using the point file of dams in Montgomery County named Mont_dams.  
 
If you do not already have the file available in the table of contents, do the following:  
 

1. Open ArcMap and a new blank map.  Click on  Add Data. 
2. Navigate to C:\USERS\”YourDirectoryID”\DOWNLOADS\Data and select the 

Mont_dams shapefile.  Click Add. 
3. Also add Montgomery_County.shp for background. 

 
Let’s pretend that we are working for Montgomery County and are looking into disaster 
planning. We’d like to know who will be affected if one or all of the dams break and how we 
can get emergency response teams to the area. We have been told by experts that we should 
be looking into a 3 mile radius of the dams (remember, this is pretend). This is a great situation 
to create a buffer. Buffers are new areas of a certain distance that can be created around 
points, lines, or polygons. We will make a 3 mile buffer around the dams to see the areas that 
will be affected if the dams break.  
 
We will use ArcToolbox to create our buffers.  

1. Click once on the Toolbox icon.    Notice that ArcToolbox is now open within 
ArcMap – you can move the toolbox window around.  
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2. Single click on the plus sign next to Analysis Tools.  
3. Single click on the plus sign next to Proximity.  
4. Double click on Buffer.  

 

   
 
 
The buffer window will open. 

 
1. In the ‘Input Features’ box at the top choose Mont_Dams from the drop down box.  

2. Using the browse icon  navigate to the Data folder in DOWNLOADS in the box for 
‘Output Feature Class’ and name the new file ‘Mont_Dams_Buffer’.  If you are unable to 
navigate to the Data folder, you can save the new buffer shapefile to the default 
geodatabase that is automatically populated. 

3. Under Distance, type in 3 for linear unit.  
4. Choose ‘Miles’. 
5. Click ‘OK’.   You will see a little progress window at the bottom of the screen, and when 

the process is complete a temporary window with a check mark will pop up. 
6. Using the ‘measure’ tool, measure a radius.  

 
The new shapefile, Mont_Dams_Buffer, now appears in the table of contents and in the map 
display.  
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Let’s look at the attribute table of the buffer file. In the table of contents, right click on 
Mont_Dams_Buffer > Open Attribute Table.  
 

 
 
 
The table shows each dam and the buffer distance of 3 miles displayed in feet (15,840 Feet = 3 
miles).  
 
 

2. Clip Operation 
 
Now that we have a 3 mile buffer of the areas that will be affected by a break in the dams, let’s 
look at who will be affected. We will use zip codes as a way to identify areas. The only zip code 
file that we could find is for the entire state of Maryland. We’d like it to be for only 
Montgomery County. This is a perfect opportunity to use the clip function.  
 
Usually associated with the “within” condition, the clip function works like a cookie cutter. In 
our case we will be using the state zip code file as the input layer (the cookie dough) and cutting 
it with Montgomery County (the cookie cutter). We’ll end up with the shape of Montgomery 
County and the attributes of the zip codes. 
 

1. Click on the add data icon.   

2. Navigate to C:\USERS\”YourDirectoryID”\DOWNLOADS\Data. 
3. Double click on mdzip_06.   

(You will get a warning about a datum conflict, and you will see that the layers do not 
quite match up.) 
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A layer for the zip codes in Maryland from 2006 will be added. Re-open the ArcToolbox 
window if it is not already open.   Under Analysis Tools > Extract, double click on Clip.  Or 
from the menu bar, click on Geoprocessing > Clip.    
 

1. Click on the drop down box under ‘Input Features’ and choose ‘mdzip_06’. 
2. Under ‘Clip Features’ choose ‘Montgomery_County’ in the drop down box.  

 
 

 
 

C:\USERS\”YourDirectoryID”\DOWNLOADS\GIS_WRKSHP 
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3. Navigate to (using the browse icon ) 
C:\USERS\”YourDirectoryID”\DOWNLOADS\Data as the location for the ‘Output 
Feature Class’.   

4. Name the file ‘MD_zip’. 
5. Click save then ‘OK’. 

 
  Let’s reorganize our layers so that we can see everything.  
 

1. Turn off md_zip06.   
2. Click on and hold the left mouse button and drag 

Mont_Dams_Buffer under Mont_Dams.  (If necessary, click on 

the “List By Drawing Order” icon    – then you will be able to 
move layers.) 

 
You should see the zip codes for Montgomery County as well as the dams and buffers around 
the dams.  
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3. Intersect  
 
Now that we have the zip codes in Montgomery County, we can use that with the buffer of the 
dams that we created. We can visually see where the overlap between the two files is, but we 
can take a closer look by using the intersection operation. 

 
 
From the ArcToolbox menu: 
 

1. Single click on the plus sign to the left of ‘Analysis 
Tools’.  

2. Single click on the plus sign to the left of 
‘Overlay’.  

3. Double click on ‘Intersect’.  
 
The Intersect window will open. 
 

1. From the Input Features drop down 
box, choose Mont_Dams_Buffer.  (It will appear in the box list area, not the drop-
down.) 

2. Repeat this process and choose the MD_zip file.  
3. Save the output file to the Data folder in DOWNLOADS and call the file   

MD_zip_Intersect. Click ‘SAVE’. 
4. Click ‘OK’. 
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Turn off all layers EXCEPT: 
 
● the newly created MD_zip_Intersect file and  
● Montgomery_County  
 
In the map display we can visually see the zip code areas 
in the 3 mile buffer.  
 
Right click on MD_zip_Intersect and open the attribute 
table.  
 
The attribute table has attribute information of both the 
zip codes and the dams that are in a 3 mile buffer of the 
dams. The shape of the file is of the shared areas.  
 
Close the attribute table.  
 

4. Dissolve  
 
Still pretending to be Montgomery County, we have decided that it would be nice to have a 
map and table of the post offices in charge of each zip code. We’d like to quickly contact the 
post offices so they can send out emergency information to the residents in the affected areas. 
As the larger areas have multiple zip codes that belong to one post office, we’d like to combine 
the areas both visually and in the attribute table. The dissolve operation is ideal for this. As the 
dissolve operation allows you the option of adding statistical fields, we use the layer we just 
created (MD_zip_intersect) and add a column with the sum of population for zip codes that are 
combined.  
 

1. Go back to ArcToolbox.  
2. Click once on the plus sign to the left of ‘Data Management Tools.’  
3. Click once on the plus sign to the left of ‘Generalization.’  
4. Double click on ‘Dissolve.’  

 
The Dissolve window will open. 
 

5. In the drop down box for ‘Input Features’ select MD_zip_Intersect.  

6. For ‘Output Feature Class’, use the browse button  and navigate to Data in 
DOWNLOADS. Save the file as “MD_zip_Intersect_Dissolve.”  

7. Check the box next to “PO_Name” in the ‘Dissolve_Field(s) box. This allows us to 
dissolve the lines that connect zip codes that are shared by the same post office 
name.  

8. Under the box for ‘Statistics Field(s) use the drop down box to select SUMBLKPOP.  
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9. In the box to the right, ‘Statistics Type,’ choose “SUM.” We are going to add a field 
to our new attribute table with population. As some areas will be combined, we’d 
like to see the combined population totals for those areas.  

10. Click “OK.”  
 

 
 
In the map display you can see that there are now 2 areas instead of 3. Open the attribute table 
by right clicking on MD_zip_Intersect_Dissolve.  You can see that all 43 zip codes are handled 
by 9 post offices. In addition, we have the combined population for those areas in a new 
column. 
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5. Spatial Join  
 
Let’s investigate another option in the toolbox. In a spatial join, fields from one layer's attribute 
table are appended to another layer's attribute table based on the relative locations of the 
features in the two layers. Let’s take a look at how it works.  
 
We will be using the TractPly and BankPt shapefiles.  Open a new map in ArcMap and add 
these two files (navigate to C:\USERS\”YourDirectoryID”\DOWNLOADS\Data). 
 
A spatial join can be useful, as in this example, for determining which points fall within 
polygons. 
 
You can perform a spatial join either through ArcToolbox or by right clicking on a layer, 
choosing Properties > Join and in the Join Data box, “Join data from another layer based on 
spatial location”.  Using ArcToolbox will give you a little more control over the details and the 
ability to exclude fields from the new attribute table if you wish, so we will use that method. 
 

 
 
From ArcToolbox,  
 

1. Left-click on the plus sign to the left of ‘Analysis 
Tools.’  

2. Left-click on the plus sign to the left of ‘Overlay’  
3. Double click on ‘Spatial Join.’  

 
 
 

 
 
 

 
 
In the ‘Spatial Join’ box, 
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1. Select “BankPt” in the drop down box under Target Features.  
2. Choose “TractPly” in the ‘Join Features’ drop down box.  
3. Navigate to the Data folder in DOWNLOADS in the ‘Output Feature Class’ box using 

the browse  icon.  
4. Name the file spatialjoin.  
5. Choose JOIN_ONE_TO_MANY.  (There may be many banks located within one census 

tract polygon.) 
6. The “Field Map of Join Features” is where you can specify if you would like to remove 

certain fields from the joined attribute table – this can be helpful if you have extraneous 
fields.  For example, all we really want out of the attribute table of the census tracts 
layer is the field containing the census tract number (TRACT), so we could remove all the 
fields after GEOID for clarity if we wanted to. 

7. Keep the remaining default values listed for the remaining boxes as well.  
8. Click ‘OK’.  Wait for the spatial join to run. 

 
 
 
A new shapefile will be added to the map and table of contents. As you can see, the shape is of 
the bank points.  
 
Let’s check the attribute table. Scroll through and see how this spatial join added the attributes 
for TractPly to the end of the BankPt file.  
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Conclusion 
 
ArcGIS Desktop has over 200 geoprocessing tools. In this tutorial, we’ve seen five of the most 
commonly used Geoprocessing tools: 
 

1. Buffer:  create a new area around an object. 
2. Clip:  create new files with the shape of one layer and the attributes of another. 
3. Intersect:  create a file with the shape of the shared areas and attributes of both 

layers. 
4. Dissolve:  remove the boundaries between adjacent areas that have the same values 

for attributes. 
5. Spatial Join:  add attributes of one file to another based on location.  

 
Operation Description Attribute 

table 
changes? 

New Shape is:  Attribute 
Table 

Toolbox location 

Buffer Creates a new polygon at a 
buffered distance around a 
point, line or another polygon.  

None New polygon of 
distance 

Attributes of 
layer 
buffered. 

Analysis 
 >Proximity 
> Buffer 

Clip Cuts out a piece of one theme 
using another theme as a "cookie 
cutter." 

None Overlay layer Input layer Analysis >Extract  
>Clip 

Dissolve Removes boundaries or nodes 
between adjacent polygons or 
lines that have the same values 
for a specified attribute. 

Yes Polygon layer of 
areas that share 
the specified 
value. 

Only contains 
values that 
the dissolve 
affects. Lose 
all other 
attributes. 

Data 
Management > 
Generalization > 
Dissolve 

Intersect Integrates two spatial data sets 
while preserving only those 
features falling within the spatial 
extent common to both themes 
(similar to Boolean AND). 

Yes Just the areas in 
common 
between the 
layers. 

Combined 
attribute 
table of all 
layers used in 
operation. 

Analysis  
> Overlay 
>Intersect 

Spatial Join Creates a table join in which 
fields from one layer's attribute 
table are appended to another 
layer's attribute table based on 
the relative locations of the 
features in the two layers. 

Yes Shape of target 
features layer 
(first one input) 

Target layer 
attribute 
table with 
join features 
attributes at 
end. 

Analysis  
> Overlay >Spatial 
Join 

Union 
Joins two layers together visually 
with the new attribute table 
consisting of shared/overlapping 
areas. NOT shown in this class. 

 

Yes Both layers used 
in operation 

Attributes of 
shared areas 

Analysis  
> Overlay  
> Union 
(Can also perform 
this via Editor 
Toolbar in 
ArcMap.)  
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Exercise: Spatial Analysis with Raster Data 
 
Background 
 
The analytical functions we have just performed in ArcGIS are based on a vector data structure 
of points, lines and polygons. As demonstrated, this data model is ideal for elements that have 
discrete boundaries like airports, highways and urban areas. But what if our data does not have 
discrete boundaries and is continuous over space (for example, elevation, slope, aspect or soil 
type)? The raster data model can be particularly beneficial in analyzing data that is continuous. 
As stated earlier, raster data is composed of a two-dimensional matrix of grid cells, with each 
cell assigned a numerical value. 
 
In the following section, we will work through some analyses that may be performed on raster 
data. Bear in mind that with raster data, even more than with vector data, for a successful 
outcome it is essential to understand the parameters of the data you’re working with and what 
you hope to achieve in your analysis.  The exercises below are simply to introduce you to where 
the tools are located and to show you some of the mechanics—for true analysis, you will have 
to make the decisions! 
 
The Spatial Analyst Extension and Toolbar 
 
In order to use the raster model in ArcGIS we need to load the Spatial Analyst extension and 
activate the Spatial Analyst Toolbar. 
  

1. Open ArcMap and create a new blank map. 
2. Click on ‘Customize’ > Extensions.  
3. Turn on ‘Spatial analyst’ by checking the box next to it. 

 
 
Examine raster data 

1. Add an elevation data to ArcMap by clicking on the Add Data icon   
2. Navigate to C:\USERS\”YourDirectoryID”\DOWNLOADS\Data \elevation. You should 

see the following image. The greater the elevation the lighter the areas looks and the 
lower elevation, darker the areas looks. However, we can use color ramps (color 
schemes) other than black to white to highlight the same information. You may have 
to take into account whether your audience may have color blindness. But for now 
let’s practice changing the color ramp. 
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3. Right click on the elevation layer and go to ‘Properties’.   

a. Look at the “Source” tab to find the size of the cells, the extent of the data, what 
spatial reference it is using. 

b. Look at the “Symbology” tab to see some color ramp options for display.   
c. If you click on color ramp, you can see the different color schemes that can be 

used to show change in elevation.  
d. These color ramps also have names. To see their names right click on “Color 

ramp” and uncheck “Graphic view”. Let’s pick “Elevation #1” for this exercise. 
e. Look at the “Extent” tab to see the coordinates of the image’s extent. 
f. Click apply 
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Surface Analysis 
 
Surface analysis produces a new dataset—this can help you identify or derive patterns within 
the original dataset that may not have been evident.  We will look at two examples: contour 
and slope.  Contour will produce a vector output, while slope will produce a raster output.  The 
raster output you get from spatial analysis on grid data can be either grid with unique values or 
Boolean. 
 
The coordinate system used for the elevation raster uses Decimal Degrees for latitude and 
longitude (X and Y) and meters for the elevations (Z). Most of the analysis we want to do using 
elevation datasets – such as creating a hill shade raster or creating contour intervals requires us 
to transform the coordinate system of the raster so that X, Y and Z are all in the same units. 
Choose the projected coordinate system that is appropriate for the area of geographic 
coverage.  
 

Project Elevation Model 
 

● Click the toolbox icon on the ArcMap toolbar to bring up the Geoprocessing Toolbox 

● Open the following chain of expandable toolsets: Data Management Tools> Projections 
and Transformations > Raster > Project Raster 

● Use pull-down menu for Input Raster to and browse to your elevation model. 
● In the Output Raster Dataset blank file location enter the Data folder in DOWNLOADS 

and name the file. Remember ArcMAP does not accept long names or spaces. 
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● In the pull-down for the Output Coordinate System choose:  Projected Coordinate 
System, State Plane, NAD 83 US Feet, then Maryland State Plane FIPS1900 US Feet and 
click ok. 

● Finally, go to the blank labeled Resampling Technique and choose Cubic 

● Click ok  
 

 
Resampling 

 
When a raster dataset is projected from a plain geographic coordinate system to a projected 
one, the size and shape off the cells is transformed. You can think of Resampling as creating a 
new grid of cells and assigning values to the new cells based on the values of the old cells. The 
default method (Nearest Neighbor Resampling) simply assigns a value to the new cell based on 
the value of the cell in the old raster that is nearest to the center of the new one. This is the 
right thing to do with rasters whose values represent categories. For rasters that represent a 
continuous surface the Nearest Neighbor method can create stair-stepped striations. For 
continuous value rasters, like elevation models, the Cubic resampling method is best. (Source: 
http://www.gsd.harvard.edu/gis/manual/dem/) 
 
 
Contour (Vector) 
 
Why might you want to see contours?  This is a very good way to look at the overall gradation 
of the land, and is familiar to the eye.  Using contour as an example also illustrates how you can 
get a vector result from a raster original. 
 
From ArcToolbox,  
 

1. Go to ArcTools and Left-click on the plus sign to the left of ‘Spatial analyst tools.’  
2. Left-click on the plus sign to the left of ‘surface’  
3. Double click on ‘Contour.’  

 
 

http://www.gsd.harvard.edu/gis/manual/dem/
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In the ‘Contour’ box, 
 

1. Select “elevation” in the drop down box under ‘Input raster’.  
2. Navigate to the Data folder in DOWNLOADS in the ‘Output polyline feature’ box using 

the browse  icon.  
3. Name the file contour1.  
4. Put ‘10’ (or your own choice) in the ‘Contour interval’.  
5. Keep the defaults for the remaining boxes.  
6. Click ‘OK.’  
7. A box showing the progress for the task will appear. When it is finished running, close 

the programming box.  
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Elevation raster data is converted into vector data—contour lines. 
 

8. Right click on contour1.shp to open the attribute table.  
9. Highlight a line and notice that the corresponding line on the map is highlighted.  

  

 
Let’s try another function from the surface menu. 
 
Slope (Grid) 
 
Examining slope tells you how steep the terrain is—this kind of output can then be analyzed 
and used for a variety of determinations such as likelihood of flooding, best places to locate 
buildings, etc.  What the software is doing in this case is calculating the maximum rate of 
change between each raster cell and its neighbors.  You can calculate your slope output either 
as percent slope or degree of slope.  We will use percent in this example, and our output will be 
a raster. 
 
From ArcToolbox,  
 

1. Go to ArcTools and Left-click on the plus sign to the left of ‘Spatial analyst tools.’  
2. Left-click on the plus sign to the left of ‘Surface’  
3. Double click on ‘Slope.’  

 
In the ‘Slope box’, 
 

1. Select “elevation” in the drop down box under ‘Input raster’.  
2. Navigate to the Data folder in DOWNLOADS in the ‘Output raster’ box using the 

browse  icon.  
3. Name the file slope1 and click save.  
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4. Put “PERCENT_RISE” in the drop down box under ‘Output measurements’.  
5. Keep the defaults for the remaining boxes.  
6. Click ‘OK.’  
7. A box showing the progress for the task will appear. When it is finished running, close 

the programming box.  
  
The resulting output is a slope map of the elevation data. The grid cells have been given new 
values based on the difference between their elevation value and that of their neighbors. In the 
example the dark areas are those with the steepest slopes. 
 

 
 
 
 
Spatial Analysis Using Map Algebra: Boolean 
 
Map algebra uses a predefined, mathematical formula applied to the corresponding cells of 
overlaid themes to create a new theme with the numerical result assigned to the cell. For 
example, if you add two themes, the value assigned to a cell will be the sum of the values of the 
cell in each old layer that corresponds to the location of the cell in the new layer.  
 

3 2 1 

0 0 1 

2 1 4 

 

8 2 4 

1 2 1 

6 2 8 

 

5 0 3 

1 2 0 

4 1 4 
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Input 1                   Input 2                Output 
Calculation: add the values of corresponding cells. 

 
Here’s another visual example.  We have two input rasters, each with cells that have values 
ranging from 0 to 5.  We’d like to compare, and find only cells where the value is not zero in 
both of the inputs.  This is what it would look like: 
 

3 2 1 

0 0 1 

2 1 4 

 

5 0 3 

1 2 0 

4 1 4 

     Input 1  Input 2 
Calculation: find where values are nonzero in the cells of both inputs. (1=true; 0=false) 

Output: 

1 0 1 

0 0 0 

1 1 1 

 
 
 
 
 
 
The formula used in map algebra can be a simple mathematical operation like addition, 
multiplication, division or subtraction (arithmetic operators), as in the first example.  Map 
algebra can also use Boolean operators (And, Or, Xor, Not) as in the second example, or it can 
use a more complex operation involving logarithms, exponents, powers and trigonometric 
functions such as sine and cosine (mathematical functions).  
 
This can be useful for detailed analysis.  You can construct mathematical formulas using the 
values of your grid cells in each layer. 
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In ArcMap with ArcToolbox open,  
 

1. Expand ‘Spatial Analyst Tools’ and ‘Map Algebra’. 
2. Double click on ‘Raster Calculator’. 
3. Use the buttons to get the following expression into the box (or directly type):   

“elevation” > 100 
4. Give the output raster a name (such as HighElev) and save it to the Data folder in 

DOWNLOADS. 
5. Click OK. If you do not see the map, zoom out. 

 
Your result will look like this: 
 

 
 
What if we want to combine two rasters?  For example, say we are growing a certain kind of 
crop that does best in areas with low elevation and slope.  We can use map algebra to find 
areas where the elevation and slope are both high and then eliminate those areas from 
consideration when we do our planting. 
 

1. Double click on the Raster Calculator tool. 
2. Use the buttons to get the following expression into the box (or directly type):  

(“elevation”>100) & (“slope1”>75.0) 
3. Give the output raster a name and save it to the Data folder in DOWNLOADS. 
4. Click OK. 

 
In the resulting raster, cells either have a value of 0 or 1.  0 indicates false and 1 indicates true.  
Therefore, the areas classed as 1 are the areas of high elevation and slope (the areas you want 
to avoid). 
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Conclusions 
 
The examples provided here are very simple ones. We could have built a query that was far more 
complex. Other areas such as wetlands, parks, etc. could have been incorporated into the model 
and eliminated from consideration.  
 
Grid analysis can be very complex. For example, you can use the themes of slopes, wetland areas, 
soils, forested areas, areas served by water/sewer utilities, proximity to transit, etc. to determine 
the best sites for building. The accuracy of the analysis depends on several things: 
 

● The accuracy and currentness of your data  The old saying “garbage in, garbage out” holds 
true here. You want to have data that is current and accurate for the purpose of your analysis. 
Spatial Analyst allows vector data to be converted to grid data so any investment in vector data 
is not lost. 

● The resolution of your data  The finer the resolution, the more detailed your analysis. You can 
set a resolution size so high that the grid data approaches vector data in appearance. The down 
side of very high resolution data is the amount of storage space that it uses. A resolution should 
be chosen appropriate to the scale for the data and the task at hand. 

● The values you assign to the cells and the appropriateness of your mathematical formula  
Spatial analysis is utlimately a judgement call of what is deemed “valuable” for some purpose, 
and your formula should be logical in its structure and sequence. The reasoning behind the 
value assignments and the formula used must be defensible. 

 
We have worked through just two spatial overlay processes. There are many other potential uses. 
Overlay analysis could be used to determine the best sites for habitat protection areas or forest 
conservation areas. It can predict areas likely to erode based on soil types, slopes and landuse. It 
can delineate areas impacted by air traffic noise. The possibilties are almost endless. The power of 
GIS is the ability to perform this analysis quickly and efficiently.  
 
 
Need to know more about raster data? 
Recommended Virtual Campus Course:  Working with Rasters in ArcGIS Desktop 
(see next page for instructions on how to sign up) 
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More Training and Information 
 
University of Maryland at College Park students, faculty, and staff have access to free online 
courses provided by ESRI. These cover a wide range of GIS topics and skills. To gain access to 
online classes, please contact kelleyo@umd.edu with the name of the course you are interested 
in and your UMD e-mail address to obtain a registration code. 
 
Course list:  https://www.esri.com/training/unlimited-esri-training/ 
 
University of Maryland Libraries’ GIS and Spatial Data Services Center website:  
http://lib.umd.edu/gis/ 
 
University of Maryland Libraries’ GIS and Spatial Data Services Center workshop series:  
https://www.lib.umd.edu/gis/workshops 
 

https://www.esri.com/training/unlimited-esri-training/
http://lib.umd.edu/gis/
https://www.lib.umd.edu/gis/workshops

